Mivec Owners Group
http://www.mivec.co.nz/forums/

Engine hesitation when accelerating
http://www.mivec.co.nz/forums/viewtopic.php?f=7&t=12368
Page 1 of 1

Author:  MSGIZA [ 13 Jan 2019 20:25 ]
Post subject:  Engine hesitation when accelerating

Please help a newbie ! I have a 1996 mitsi lancer mivec . I got the car fairly cheap from a friend. But when i put my foot down it hesitates and kinda sounds like a suby ..it takes awhile to go away then it just takes off . Its frustrating me and i wish to know what is causing thw problem so i can fix it ! Please help

Author:  MSGIZA [ 14 Jan 2019 21:54 ]
Post subject:  Re: Engine hesitation when accelerating

Also i must add that there is no check engine light so i cant scan it . I have tried the leads and tested numerous coil packs ( new and used ) to no avail. I have changed the air filter . I bought the car with new spark plugs but am unable to check them without the correct tool . I am stuck and not sure what i should be checking for next .

Author:  magn1t [ 15 Jan 2019 21:12 ]
Post subject:  Re: Engine hesitation when accelerating

Random changing of parts is always a fail.

Take a look at the sparkplugs and report back.



Look mean look as in take a pic and post up on here.


The last owner got rid of it for a reason.
Are the plugs even the correct ones?

Author:  Damian [ 18 Jan 2019 02:55 ]
Post subject:  Re: Engine hesitation when accelerating

Check any little rubber pipes around the intake. My map sensor pipe perished and whilst it looked good from the outside, it was leaking bad.

Author:  MSGIZA [ 24 Jan 2019 09:24 ]
Post subject:  Re: Engine hesitation when accelerating

I shall check the rubbers at some stage today and get back to you .she got rid of it because she bought an r32 and had another car in her driveway .at that time our petrol prices were super high so it didnt make sense for her to keep 3 cars. It had also previously been stolen and recovered and she said it didnt feel like hers anymore . I knew that it had that hesitation problem when i bought it but i didnt think itd be this much of a headache to figure out

Author:  MSGIZA [ 29 Jan 2019 20:28 ]
Post subject:  Re: Engine hesitation when accelerating

So we ended up grinding a spark plug socket down to fit the hole . Plugs were absolutey fine . Normal . Leads wer tested .they also fine . We have checked rubbers and nothing out of the ordinary . I have put some injector cleaner into the tank as it was suggested that number 4 sounded weak .

Author:  MSGIZA [ 29 Jan 2019 20:29 ]
Post subject:  Re: Engine hesitation when accelerating

magn1t wrote:
Random changing of parts is always a fail.

Take a look at the sparkplugs and report back.



Look mean look as in take a pic and post up on here.




The last owner got rid of it for a reason.
Are the plugs even the correct ones?



So we ended up grinding a spark plug socket down to fit the hole . Plugs were absolutey fine . Normal . Leads wer tested .they also fine . We have checked rubbers and nothing out of the ordinary . I have put some injector cleaner into the tank as it was suggested that number 4 sounded weak .

Page 1 of 1 All times are UTC + 12 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/