Mivec Owners Group

It is currently 23 Aug 2014 10:35

All times are UTC + 12 hours [ DST ]




Post new topic Reply to topic  [ 29 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 18 Aug 2009 07:00 
Hi guys!

I've been reading along for a while and I think it's time to start my own thread.

A few years ago I bought myself a Mitsubishi Colt. This is the European variant of the Mirage. It's only available with the 4g13 engine :oops:
I made a few modifications on the exhaust and intake but that was all... I would like to make it a showcar. Because there were not so many parts on the EU market, it wasn't easy. I decided to make my own parts.
For 3 years the car drove like the pics below...

One day, a friend took me to the Nurburgring in Germany. We did a few laps and I was in love with the circuit! From this day forward I wanted a car to drive trackdays.
I started to rebuild my Colt from showcar to 'racecar'. There was only 1 problem, POWER :roll:

I knew there was a fast Mitsubishi hatch in Japan, the cyborg. I did some research and I found the 4G92 Mivec fitted my enginebay :D I searched a long time in the EU but there was nothing to be found! Then I contacted somebody that imports cars and he deliverd me a frontcut with the 4G92 :P

There was only one problem, my car has the steeringwheel on the left, where a mirage has it on the right :|
I had to customize all the electrics that came with the frontcut because I didn't want to ruine mine :oops:
There were some more issues but they were cleared without much troubles.


Attachments:
2 (154)kl.jpg
2 (154)kl.jpg [ 77.47 KiB | Viewed 4068 times ]
2 (155)kl.jpg
2 (155)kl.jpg [ 77.78 KiB | Viewed 4068 times ]
09-11-2006_00001.jpg
09-11-2006_00001.jpg [ 81.04 KiB | Viewed 4068 times ]
1 (59)klein$.jpg
1 (59)klein$.jpg [ 23.28 KiB | Viewed 4068 times ]
Top
  
 
PostPosted: 18 Aug 2009 07:45 
Today, my Colt has got a brand new look! It has only one goal, trackdays 8)
Because a standard colt has no intention for circuit use, I made some modifications.

Engine:
- 4g92 mivec (Gen2)
- Cusco clutch-kit

Intake:
- sparco filter

Exhaust:
- custom made piping without cat

Suspension/steering:
- KW adjustable kit
- Cusco pillowball uppermounts (front+rear)
- Cusco front swaybar
- Cusco rear swaybar
- Cusco front lower brace
- Cusco rear lower arm
- SUMMIT front strutbar
- SUMMIT rear strutbar

Wheels/tires:
- Allessio 7.5x17 & EVOX 7.5x17
- Toyo R888 205/40/17
- Lenso 7.5x16
- Federal 595RS-R 205/45/16

Brakes:
- Wilwood 4-pot calipers (front + rear)
- 300mm front drilled + slotted disc's
- 280mm rear drilled + slotted disc's
- evo3 1" brake master cilinder
- stainless braided flexible brake lines
- Ferodo DS2500 brake pads

Electronics:
- apexi RSM

Interior:
- Sparco seats
- Sparco seatbelts
- Carbon door- and sidepanels


There will come some more mods with time but this is it for now :)


Attachments:
blikveld 4 jul 2009_00001.jpg
blikveld 4 jul 2009_00001.jpg [ 84.29 KiB | Viewed 4065 times ]
blikveld 4 jul 2009_00002.jpg
blikveld 4 jul 2009_00002.jpg [ 76.93 KiB | Viewed 4065 times ]
blikveld 4 jul 2009_00003.jpg
blikveld 4 jul 2009_00003.jpg [ 85.25 KiB | Viewed 4065 times ]
Top
  
 
PostPosted: 18 Aug 2009 08:03 
Before I fitted the 4g92 in my enginebay, I gave it a little maintenance...

- new oil pump
- new water pump
- new sparkplug cables
- new timing belt
- new auto tensioner
- new pulley's
- new engine mounts
- new filters
- new coolant
- new MOTUL 10w40
- new MOTUL 75w90

When the gearbox was removed, I noticed the flywheel was damaged so this was replaced by the cusco lightweight one.

The original air filter had to make place for the sparco filter.


Attachments:
engine_00018.jpg
engine_00018.jpg [ 91.39 KiB | Viewed 4065 times ]
ringer_00073.jpg
ringer_00073.jpg [ 84.73 KiB | Viewed 4065 times ]
engine_00021.jpg
engine_00021.jpg [ 86.79 KiB | Viewed 4065 times ]
Top
  
 
PostPosted: 18 Aug 2009 08:12 
Before the 4g92 was swapped, I allready did some modifications on the brakes.
Standard brakes are very poor I must say...
So these were very fast replaced by larger examples...


Attachments:
STP62846k.jpg
STP62846k.jpg [ 73.14 KiB | Viewed 4065 times ]
STP62855k.jpg
STP62855k.jpg [ 71.4 KiB | Viewed 4065 times ]
ringer_00020.jpg
ringer_00020.jpg [ 89.57 KiB | Viewed 4065 times ]
ringer_00039.jpg
ringer_00039.jpg [ 81.87 KiB | Viewed 4065 times ]
Top
  
 
PostPosted: 18 Aug 2009 09:36 
Offline

Joined: 02 Mar 2009 06:32
Posts: 41
Country: Scotland
very nice man what rear bumper is that?

steve


Top
 Profile  
 
PostPosted: 19 Aug 2009 01:23 
That's selfmade stuff :)
Because there are not alot of aftermarket parts I like, I 've made them myself. The diffusor is in carbon.

Grtz


Top
  
 
PostPosted: 20 Aug 2009 07:21 
Offline

Joined: 15 Feb 2009 07:53
Posts: 132
Location: Reading/UK
This car just looks awesome. Ive watched the video on youtube of how the car changes from standard to this and its just amazing. I would love to know how you made the body kit as i absolutely love it.


Top
 Profile  
 
PostPosted: 20 Aug 2009 10:03 
Thanks!
I've spent a lot of hours/days/weeks on making the kit... I've started from the original bumpers and I worked my way out with cardboard and lots of tape untill I got the rough shape. Put polyester over it and start with lots of filler where can make the nice smooth shape from. This you can use to make a mould. In this mould you can make your new bumper 8)
It's a dirty job but I think the result is worth it. :)

Greetz


Top
  
 
PostPosted: 22 Oct 2009 08:24 
some bad news, engine got killed in action last wednesday on track... :cry:
I think pics say more than words...
Image
Image
Image


Top
  
 
PostPosted: 22 Oct 2009 12:56 
Offline
User avatar

Joined: 14 Apr 2009 22:40
Posts: 178
Location: Welly, Nouvelle-Zélande
Country: New Zealand
Not good. Any idea what caused it, was it detonation or oiling issues?

_________________
'00 White Lancaster6 (towboat)
Used to have a 97 RS... miss it already


Top
 Profile  
 
PostPosted: 23 Oct 2009 05:37 
Offline
User avatar

Joined: 09 Feb 2006 04:31
Posts: 250
Location: Greece / Thessaloniki
Country: Greece
very nice car!!!!!!!too bad for the damage!!!!!!!!!! :cry:

_________________
http://www.youtube.com/watch?v=OVibdD5tuJQ


Top
 Profile  
 
PostPosted: 24 Oct 2009 09:11 
I've got no idea what caused this damage... It might have been one thing that let to another and so on... Really not a clue....

I bought the engine with 107.000 km's on the clock in the beginning of this year... I can only imagine what previous onwers have done to this engine. Was it always serviced? I only replaced the parts I've described in a previous post, I did not open the engine to see what kind of condition it was in.
I drove it gently the first month to losen it up a bit... Everything went smooth and there were no problems or noises... After 1500 km's I went on a trackday without many problems... I did notice the oil temp went up to 150°C top. The track I drove takes lots of all the cars. Heavy braking, chicanes, ... Next time i went to another track, the oil temp stayed at 120-130°C. I did want to install an oil-cooler but I didn't bought one yet. Damn me!! So maybe high oil temp could have caused some damage... :oops: Although I thougt MOTUL (10w40) can handle higher temps...?
When the engine blew up, all temps were ok (water, oil) The oil level was ok when I started, I checked it 10 minutes before. It wa only lap 6 so I didn't push it, yet :roll:
There were no rattling or weird noises...
Other pistons don't show anything abnormal (besides the damage from the crash, scrathes etc)

There's not much I can re-use from this engine because there's a lot of damage from parts that went around in the engine when it gave up (@ 7000rpm)
I checked my local dealer for a new engine but he couldn't give me a price because this engine doesn't exist in Europe. I'll give him some time to make some calls and sent some e-mails :roll:

This really sucks because there are only 110 000 km on the clock...


Top
  
 
PostPosted: 24 Oct 2009 09:19 
Offline
User avatar

Joined: 09 Feb 2006 04:31
Posts: 250
Location: Greece / Thessaloniki
Country: Greece
i have a friend dealer in Athens of Greece for japanese cars only he has a mivec engine gen2 for replace pm if you interest to give you info!!!!!My damage in my mivec was very worse than yours!!!!!!!

_________________
http://www.youtube.com/watch?v=OVibdD5tuJQ


Top
 Profile  
 
PostPosted: 24 Oct 2009 11:02 
Offline
User avatar

Joined: 14 Apr 2009 22:40
Posts: 178
Location: Welly, Nouvelle-Zélande
Country: New Zealand
When you say the oil level was OK, was it above the "full" mark? I usually ensure the oil is at least sitting on the full mark, preferably a touch over. The 'minimum' mark on the dipstick is too low for spirited driving, especially since mivecs will use a little oil.

Getting the oil too hot can cause problems, something to do with 'coking' the oil which stuffs it up somehow (all a bit beyond me). However if you've not done this multiple times in a row the oil should be OK I would think...

Best of luck getting it sorted out, at any rate.

_________________
'00 White Lancaster6 (towboat)
Used to have a 97 RS... miss it already


Top
 Profile  
 
PostPosted: 24 Oct 2009 18:58 
Offline
User avatar

Joined: 15 Dec 2005 04:42
Posts: 176
Location: Penang
Country: Malaysia
you had a nice car.....

i don't think the oil temp was causing the problem....
i had the same problem at the passed track day, that time my oil temp just show around 120 Deg C only....
And i had installed the oil cooler for it, but end up the bearing still faulty after 10km distance...... :lol:
So i suspect the oil level causing the problem....

I will try to fill up enough oil level during the next track day race again.....

_________________
Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 29 posts ]  Go to page 1, 2  Next

All times are UTC + 12 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group